re = /(Ausdruck1|Ausdruck2|Ausdruck3)(?=.*AusdruckA)/
str = 'Ausdruckc123 !!!Ausdruck3 AusdruckA
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end