$re = '/(Ausdruck1|Ausdruck2|Ausdruck3)(?=.*AusdruckA)/';
$str = 'Ausdruckc123 !!!Ausdruck3 AusdruckA
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);