$re = '/(?=.*?[a-z])(?=.*?\')[a-z\']+/mi';
$str = '\'word\'
\'Word
\'W\'ord
\'W\'or\'d
Word\'
w\'orD
w\'o\'r\'d
word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);