re = /(?=.*?[a-z])(?=.*?')[a-z']+/mi
str = '\'word\'
\'Word
\'W\'ord
\'W\'or\'d
Word\'
w\'orD
w\'o\'r\'d
word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end