using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s*•.*)\.$";
string substitution = @"$1";
string input = @"• this is a test bullet.
• this is a test bullet 2.
• this is a test bullet 3.
sdjhdjs.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}