re = /^(\s*•.*)\.$/m
str = '• this is a test bullet.
• this is a test bullet 2.
• this is a test bullet 3.
sdjhdjs.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result