$re = '/^(\s*•.*)\.$/m';
$str = '• this is a test bullet.
• this is a test bullet 2.
• this is a test bullet 3.
sdjhdjs.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;