using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*\d)(?=.*[a-z])(?=.*[A-Z])[\da-zA-Z]{8,}";
string input = @"11111111
111kjKJHo
dllkjgvsc8jK
Ssa83Oinjdg
aaaaaaaaaa
aaaaaaaa4E";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}