$re = '/(?=.*\d)(?=.*[a-z])(?=.*[A-Z])[\da-zA-Z]{8,}/m';
$str = '11111111
111kjKJHo
dllkjgvsc8jK
Ssa83Oinjdg
aaaaaaaaaa
aaaaaaaa4E';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);