re = /(?=.*\d)(?=.*[a-z])(?=.*[A-Z])[\da-zA-Z]{8,}/m
str = '11111111
111kjKJHo
dllkjgvsc8jK
Ssa83Oinjdg
aaaaaaaaaa
aaaaaaaa4E'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end