#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]{4}|[0-9]{2})(\.[0-9]{1,2})?(\.[0-9]{1,2})?(-([0-9A-Za-z\-]+(\.[0-9A-Za-z\-]+)*))?$"
Local $sString = "# YYYY.MM.XX" & @CRLF & _
"2024" & @CRLF & _
"2024.01" & @CRLF & _
"2024.01.01" & @CRLF & _
"" & @CRLF & _
"# YY.MM.XX" & @CRLF & _
"24" & @CRLF & _
"24.01" & @CRLF & _
"" & @CRLF & _
"# YY.M.X" & @CRLF & _
"24.1" & @CRLF & _
"24.1.1" & @CRLF & _
"" & @CRLF & _
"2024.01.01-dev.prerelease"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")