package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]{4}|[0-9]{2})(\.[0-9]{1,2})?(\.[0-9]{1,2})?(-([0-9A-Za-z\-]+(\.[0-9A-Za-z\-]+)*))?$`)
var str = `# YYYY.MM.XX
2024
2024.01
2024.01.01
# YY.MM.XX
24
24.01
# YY.M.X
24.1
24.1.1
2024.01.01-dev.prerelease`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}