import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]{4}|[0-9]{2})(\\.[0-9]{1,2})?(\\.[0-9]{1,2})?(-([0-9A-Za-z\\-]+(\\.[0-9A-Za-z\\-]+)*))?$";
final String string = "# YYYY.MM.XX\n"
+ "2024\n"
+ "2024.01\n"
+ "2024.01.01\n\n"
+ "# YY.MM.XX\n"
+ "24\n"
+ "24.01\n\n"
+ "# YY.M.X\n"
+ "24.1\n"
+ "24.1.1\n\n"
+ "2024.01.01-dev.prerelease";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}