using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\skeyword\s|\skey\s|\s)";
string input = @"[] []
[] keyword []
[] key []
[] [""can contain spaces""]
[] keyword [""can contain spaces""]
[] key [""can contain spaces""]
{} {}
{} keyword {}
{} key {}
{} {""can"":""contain spaces""}
{} keyword {""can"":""contain spaces""}
{} key {""can"":""contain spaces""}
string string
string keyword string
string key string";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}