package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\skeyword\s|\skey\s|\s)`)
var str = `[] []
[] keyword []
[] key []
[] ["can contain spaces"]
[] keyword ["can contain spaces"]
[] key ["can contain spaces"]
{} {}
{} keyword {}
{} key {}
{} {"can":"contain spaces"}
{} keyword {"can":"contain spaces"}
{} key {"can":"contain spaces"}
string string
string keyword string
string key string`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}