// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\skeyword\s|\skey\s|\s)").unwrap();
let string = "[] []
[] keyword []
[] key []
[] [\"can contain spaces\"]
[] keyword [\"can contain spaces\"]
[] key [\"can contain spaces\"]
{} {}
{} keyword {}
{} key {}
{} {\"can\":\"contain spaces\"}
{} keyword {\"can\":\"contain spaces\"}
{} key {\"can\":\"contain spaces\"}
string string
string keyword string
string key string";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}