using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z]{3}(?(?=.*&)"".*""|.*)$";
string input = @"//good
aBc....,,,,
aBc""....,&,,""
//bad
aBc....,&,,
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}