re = /^[A-Za-z]{3}(?(?=.*&)".*"|.*)$/m
str = '//good
aBc....,,,,
aBc"....,&,,"
//bad
aBc....,&,,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end