$re = '/^[A-Za-z]{3}(?(?=.*&)".*"|.*)$/m';
$str = '//good
aBc....,,,,
aBc"....,&,,"
//bad
aBc....,&,,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);