import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<!--\\s+LOCALE(?:\\s+|\\s+uk\\s+)-->[\\s\\S]*?<!--\\s+\\/LOCALE\\s+-->)";
final String string = "$test = '<input type=\"hidden\" name=\"submitted\" value=\"TRUE\" />\n"
+ " <!-- LOCALE uk -->\n"
+ " <h2 class=\"\">Required Information UK</h2>\n"
+ " <!-- /LOCALE -->\n"
+ "<!-- LOCALE uk --><h2 class=\"\">Required Information UK</h2><!-- /LOCALE -->\n"
+ "<!-- LOCALE ru -->\n"
+ "<h2 class=\"\">Required Information RU</h2>\n"
+ "<!-- /LOCALE -->\n\n"
+ "<!-- LOCALE -->\n"
+ "<h2 class=\"\">Required Information EMPTY</h2>\n"
+ "<!-- /LOCALE -->\n"
+ "<div class=\"content_indent\" style=\"width: 764px; margin-bottom: 35px;\">';";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}