$re = '/(<!--\s+LOCALE(?:\s+|\s+uk\s+)-->[\s\S]*?<!--\s+\/LOCALE\s+-->)/im';
$str = '$test = \'<input type="hidden" name="submitted" value="TRUE" />
<!-- LOCALE uk -->
<h2 class="">Required Information UK</h2>
<!-- /LOCALE -->
<!-- LOCALE uk --><h2 class="">Required Information UK</h2><!-- /LOCALE -->
<!-- LOCALE ru -->
<h2 class="">Required Information RU</h2>
<!-- /LOCALE -->
<!-- LOCALE -->
<h2 class="">Required Information EMPTY</h2>
<!-- /LOCALE -->
<div class="content_indent" style="width: 764px; margin-bottom: 35px;">\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);