const regex = /(<!--\s+LOCALE(?:\s+|\s+uk\s+)-->[\s\S]*?<!--\s+\/LOCALE\s+-->)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<!--\\s+LOCALE(?:\\s+|\\s+uk\\s+)-->[\\s\\S]*?<!--\\s+\\\/LOCALE\\s+-->)', 'gim')
const str = `\$test = '<input type="hidden" name="submitted" value="TRUE" />
<!-- LOCALE uk -->
<h2 class="">Required Information UK</h2>
<!-- /LOCALE -->
<!-- LOCALE uk --><h2 class="">Required Information UK</h2><!-- /LOCALE -->
<!-- LOCALE ru -->
<h2 class="">Required Information RU</h2>
<!-- /LOCALE -->
<!-- LOCALE -->
<h2 class="">Required Information EMPTY</h2>
<!-- /LOCALE -->
<div class="content_indent" style="width: 764px; margin-bottom: 35px;">';`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}