#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$\d{3,}\.\d{2}"
Local $sString = "1001: $496.80" & @CRLF & _
"1002: $1290.89" & @CRLF & _
"1003: $26.43" & @CRLF & _
"1004: 613.42" & @CRLF & _
"1005: 7.61" & @CRLF & _
"1006: $414.90" & @CRLF & _
"1007: $25.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")