using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\d{3,}\.\d{2}";
string input = @"1001: $496.80
1002: $1290.89
1003: $26.43
1004: 613.42
1005: 7.61
1006: $414.90
1007: $25.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}