import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\d{3,}\\.\\d{2}";
final String string = "1001: $496.80\n"
+ "1002: $1290.89\n"
+ "1003: $26.43\n"
+ "1004: 613.42\n"
+ "1005: 7.61\n"
+ "1006: $414.90\n"
+ "1007: $25.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}