using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((1|01|001)*(0|00|0?)*)";
string input = @"01
01
001
0
00
0010010011111111100";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}