package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((1|01|001)*(0|00|0?)*)`)
var str = `01
01
001
0
00
0010010011111111100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}