import re
regex = re.compile(r"""
((1|01|001)*(0|00|0?)*)
""", flags=re.VERBOSE)
test_str = ("01\n"
"01\n"
"001\n"
"0\n"
"00\n"
"0010010011111111100")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")