package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[#@]\w\S*\b`)
var str = `This is @nick.name here
This is @nick_name here
This is @-nick.name- here`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}