re = /[#@]\w\S*\b/
str = 'This is @nick.name here
This is @nick_name here
This is @-nick.name- here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end