$re = '/[#@]\w\S*\b/';
$str = 'This is @nick.name here
This is @nick_name here
This is @-nick.name- here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);