const regex = /web_logfield[^,]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('web_logfield[^,]+', 'g')
const str = `web_logfield_A, web_logfield_B ,web_logfield_C::abc, apach_logfield_A, apach_logfield_A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}