$re = '/web_logfield[^,]+/';
$str = 'web_logfield_A, web_logfield_B ,web_logfield_C::abc, apach_logfield_A, apach_logfield_A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);