// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"web_logfield[^,]+").unwrap();
let string = "web_logfield_A, web_logfield_B ,web_logfield_C::abc, apach_logfield_A, apach_logfield_A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}