using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=id=""_wpnonce"" name=""_wpnonce"" value="").*?(?="")";
string input = @"<form method=""post"" enctype=""multipart/form-data"" class=""wp-upload-form"" action=""http://localhost/wp-admin/update.php?action=upload-plugin"">
<input type=""hidden"" id=""_wpnonce"" name=""_wpnonce"" value=""a7a9167537""><input type=""hidden"" name=""_wp_http_referer"" value=""/wp-admin/plugin-install.php?tab=upload""> <label class=""screen-reader-text"" for=""pluginzip"">Plugin zip file</label>
<input type=""file"" id=""pluginzip"" name=""pluginzip"">
<input type=""submit"" name=""install-plugin-submit"" id=""install-plugin-submit"" class=""button"" value=""Install Now"" disabled=""> </form>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}