import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=id=\"_wpnonce\" name=\"_wpnonce\" value=\").*?(?=\")";
final String string = "<form method=\"post\" enctype=\"multipart/form-data\" class=\"wp-upload-form\" action=\"http://localhost/wp-admin/update.php?action=upload-plugin\">\n"
+ " <input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"a7a9167537\"><input type=\"hidden\" name=\"_wp_http_referer\" value=\"/wp-admin/plugin-install.php?tab=upload\"> <label class=\"screen-reader-text\" for=\"pluginzip\">Plugin zip file</label>\n"
+ " <input type=\"file\" id=\"pluginzip\" name=\"pluginzip\">\n"
+ " <input type=\"submit\" name=\"install-plugin-submit\" id=\"install-plugin-submit\" class=\"button\" value=\"Install Now\" disabled=\"\"> </form>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}