import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![äöüÄÖÜß\\w])([äöüÄÖÜß\\w]+)(?![äöüÄÖÜß\\w])";
final String string = "While there was troublein town 333 wäs, nöö, söö, sää sü üs the 12 Tus tus people decided to let the love in their door. säwööo kk.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}