re = /(?<![äöüÄÖÜß\w])([äöüÄÖÜß\w]+)(?![äöüÄÖÜß\w])/
str = 'While there was troublein town 333 wäs, nöö, söö, sää sü üs the 12 Tus tus people decided to let the love in their door. säwööo kk.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end