$re = '/(?<![äöüÄÖÜß\w])([äöüÄÖÜß\w]+)(?![äöüÄÖÜß\w])/';
$str = 'While there was troublein town 333 wäs, nöö, söö, sää sü üs the 12 Tus tus people decided to let the love in their door. säwööo kk.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);