const regex = /^(?!.*7474).*1221/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*7474).*1221', 'gm')
const str = `7777 1221 4543
7777 1221 7474 4543
7474 4543 7777 1221
4543 7474 7777 1221`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}