re = /^(?!.*7474).*1221/m
str = '7777 1221 4543
7777 1221 7474 4543
7474 4543 7777 1221
4543 7474 7777 1221'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end