$re = '/^(?!.*7474).*1221/m';
$str = '7777 1221 4543
7777 1221 7474 4543
7474 4543 7777 1221
4543 7474 7777 1221';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);