using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+):(?|([^""\s]+)|""([^""]+))";
string input = @"song:""Sweet Home Alabama"" fruit:apple color:blue motto:""Don't Worry""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}