$re = '/(\S+):(?|([^"\s]+)|"([^"]+))/';
$str = 'song:"Sweet Home Alabama" fruit:apple color:blue motto:"Don\'t Worry"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);