re = /(\S+):(?|([^"\s]+)|"([^"]+))/
str = 'song:"Sweet Home Alabama" fruit:apple color:blue motto:"Don\'t Worry"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end