using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^_\w](sso\b)";
string input = @" if(s.successProperty) {
this.getSuccess = this.createAccessor(s.successProperty);
em_sso emsso_test 'sso'";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}