// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^_\w](sso\b)").unwrap();
let string = " if(s.successProperty) {
this.getSuccess = this.createAccessor(s.successProperty);
em_sso emsso_test 'sso'";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}