const regex = /[^_\w](sso\b)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^_\\w](sso\\b)', '')
const str = ` if(s.successProperty) {
this.getSuccess = this.createAccessor(s.successProperty);
em_sso emsso_test 'sso'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}