# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Dogs(?=(?:[^"]*"[^"]*")*[^"]*$)/Cats/gi;t' <<< "Dogs are scary.
Dogs are scary but my mom told me that \"Dogs are cute\""