$re = '/Dogs(?=(?:[^"]*"[^"]*")*[^"]*$)/i';
$str = 'Dogs are scary.
Dogs are scary but my mom told me that "Dogs are cute"';
$subst = "Cats";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;